本体と プラグインを アプデした

      2015/04/25

昨日、twitterで見かけたWordPressの脆弱性。
先日、本体のマイナーアップデートがあったばかりやけれど、
脆弱性が指摘されたプラグインのアップデートとともに、
今日、本体のメジャーアップデートも発表された。
データベースやPHPのバックアップをとってから、
セキュリティ対策のため、アップデート実施。
この記事は、すべての作業を終了後に書いている。
続きを読む前に愛ある応援ポチッとな♪
にほんブログ村 小遣いブログ ネットビジネス起業・独立へ
にほんブログ村

WordPressのフォーラムを読むと、
今回のメジャーアップデートを実施したら、記事の投稿ができなくなったという事例も。
どうやら、入れているプラグインの問題らしいけれど、
そんなのを読むと、メジャーアップデート、やっていいのか、ものすごく迷った。

でも、今回は脆弱性が指摘されて、セキュリティ対策のためか、
マイナーアップデートからあまり日をあけずに、
メジャーアップデートが実施されている。

メジャーアップデートの場合、アプデのあと、使用に伴い、
不具合が報告され、その修正版のマイナーアップデートが発表される。
だから、修正版が出てから、アップデートした方がいい、と勧めているヒトも。

セキュリティ絡みじゃなかったら、ちょっと様子見したけれど、
そんな悠長なことは言っていられないような・・・。
やるしかないよなぁ・・・。

ドキドキしながら、まず、プラグインのアップデートをやる。
6個もあるよ、とほほ・・・。

それから、WordPressのデフォルトテーマもアップデートをする。
自分が使っていないでゴルトテーマを済ませてから、
最後に使っているテーマをアップデート。
テーマをアップデートすると、カスタマイズしたCSSの記述も、
書き換えられてしまう。
それを防ぐために、子テーマを作り、そちらをカスタマイズしているけれど、
functions.phpだけは、親テーマのそれをまず読みに行くので、
親テーマのfunctions.phpでカスタマイズした記述箇所を、探してまた書く。

よし、これで大丈夫・・・。

それらの作業を済ませ、今こうして記事を書いているけれど、
今のところ、不具合はなさげ・・・というか、
私がすぐに気がつくほど、トンデモナイ不具合は起きていない。

まあ・・・。

私、WordPress使いとしては、ポンコツへっぽこなので、
あまりアテにならないかもしれないけれど~~~。
何か、不具合があったら、ぼそっと記事に書くかも。

WordPress本体とプラグイン、アップデートしよう~~~。
セキュリティ対策のために。


人気ブログランキングへ

 - PC研究会?, WordPress